Unexpected Service Disruption
Incident Report for Paychoice
Resolved
This incident has been resolved. More details will be provided in the post mortem.
Posted Nov 11, 2022 - 00:17 AEDT
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 11, 2022 - 00:17 AEDT
Investigating
Our engineers are currently investigating an issue on our servers.
Posted Nov 10, 2022 - 23:37 AEDT
This incident affected: PayChoice API and PayChoice CRM.